All MetalShaping

All MetalShaping (https://www.allmetalshaping.com/index.php)
-   Shop Safety (https://www.allmetalshaping.com/forumdisplay.php?f=42)
-   -   Zapped while tig welding (https://www.allmetalshaping.com/showthread.php?t=20642)

Don Papenburg 09-02-2021 09:13 PM

If all of the above do not cure the zaps pull the face off the electric panel . A loose wire on one or all of the hots and or ground will make you light up.

Harpkatt 09-09-2021 05:14 PM

I will be back to my shop this weekend finally, I will report back with my solution.

Hotflint 09-12-2021 12:46 PM

I also have the Lincoln Square wave 200. I really like it. I am glad I found this thread, I will definitely be following

Harpkatt 09-12-2021 09:01 PM

After following everyone's advise to check connections, grounds and terminations. I found the issue after I pulled the case apart...The amptroller connection turned out to be the issue. The big label that says "make sure this connection is tight" should've been a good tip. That said, I did start running a dehumidifier in my shop since its eternally damp in there. So while damp gloves may have been a contributing factor before I'll never know. That said, it works. I'm zap free and that's as much as I can ask for.

Thanks for the help.

boltboy49 09-13-2021 10:11 AM

I'm glad you got the issue resolved. And the dehumidifier sounds like it will make things more comfortable.


All times are GMT -5. The time now is 12:17 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.